PDA

Prikaži potpunu verziju : RTV Laki Pingvini - problem


milke
2.6.2006, 1:11
prateći manje-više upustva data u novom SK-u, skinuo sam i instalirao sam XdTV na SUSE 10. Imam Winfast 2000 XP i već je funkcionisala na kdetv-u, pa u tome nije problem...
Skinuo sam, komajlirao i instalirao i lirc (lirc-0.8.0.tar.bz2), ali kad pokušam da lodujem modul, javlja se sledeća greška :

# modprobe lirc_gpio
FATAL: Error inserting lirc_gpio (/lib/modules/2.6.13-15-default/kernel/drivers/char/lirc/lirc_gpio.ko): Invalid request code
Tu sam zaglavio.... Šta sad ?

Miloš
2.6.2006, 2:18
Ја мислим да си погрешио у томе што си га инсталирао из sourcea, а не из YaST-a пошто се LIRC налази на SuSE-овом инсталационом диску. Ја сам проверио код мене у YaST-у и инсталиран ми је, а покушао сам да употребим команду #modprobe lirc_gpio и функционише. Мени једино пада на памет да провериш у YaST-у да ли је инсталиран и да га макнеш ако јесте, а затим да распакујеш поново пакет са LIRC-овим изворним кодом и да куцаш ово:$make
$su
Password:
#make uninstall
Тиме би LIRC био потпуно деинсталиран, након чега можеш да га инсталираш из YaST-a или из sourcea пошто је, чини ми се, новији. Нисам сигуран да ће функционисати, али пробај.

milke
3.6.2006, 12:56
Uradih baš tako, pošto sam već imao instaliran lirc u Yastu, obrisao sam ga, uninstalirao source, i onda ponovo instalirao lirc iz Yasta. Ali sad je drugi problem :

linux:/Install/lirc-0.8.0 # modprobe lirc_gpio
WARNING: Could not open '/lib/modules/2.6.13-15-default/misc/lirc_dev.ko': No such file or directory
FATAL: Error inserting lirc_gpio (/lib/modules/2.6.13-15-default/kernel/drivers/char/lirc/lirc_gpio.ko): Unknown symbol in module, or unknown parameter (see dmesg)


Ima li neko neku ideju ? Ja sam očigledno početnik, ali bih voleo da poteram remote na poslušnost.

hvala

urke
4.6.2006, 15:59
Probaj prvo kao root da odradiš depmod -A pa pokušaj opet da učitaš modul sa modprobe lirc_gpio.

milke
5.6.2006, 0:08
kad izbrišem lirc iz yasta, i instaliram ga iz sourcea, evo rezultata : linux:/Install/lirc-0.8.0 # depmod -A
linux:/Install/lirc-0.8.0 # modprobe lirc_gpio
FATAL: Error inserting lirc_gpio (/lib/modules/2.6.13-15-default/kernel/drivers/char/lirc/lirc_gpio.ko): Invalid request code

urke
6.6.2006, 17:15
Pogledaj malo Google (http://www.google.com/search?q=Error+inserting+lirc_gpio+lirc_gpio.ko+In valid+request+code)

mladenko
9.6.2006, 13:55
Pogledaj malo Google (http://www.google.com/search?q=Error+inserting+lirc_gpio+lirc_gpio.ko+In valid+request+code)

E izem ti odgovor...

Probaj preko Yasta da podesiš TV kartu. Ideš na Hardware pa TV, izabereš svoju kartu, "Configure", klikćeš Next dok ne dođeš do pitanja hoćeš li da koristiš LIRC ili ne odgovoriš da hoćeš i pod modules izabereš gpio modul. To bi trebalo da radi.

urke
14.6.2006, 13:55
Izvinjavam se, nisam znao da iza desetine klikova stoji skrivena opcija za LIRC :)

milke
28.6.2006, 2:04
Ljudi, hvala na odgovorima, iako sa malim zakašnjenjem :)
Probao sam to iz Yasta, ali sam daljinac isprobao u konzoli, nisam mogao na TV-u :(
Izgleda da je nastao problem kad sam instalirao ATI drajvere, konfigurisao xorg.conf i sad grafička lepo šljaka, ali kdetv prijavljuje
Video plugin Error - kdetv
Unable to grab video.
Video display is not possible with the current plugin configuration. Try playing with the configuration options of V4L plugn.
Video4Linux, Video4Linux2 i XVideo plugnovi su svi uključeni, ali nije do toga... Pokušavao sam sa googlom, nalazio slična pitanja ali bez odgovora !?

Računam da je verovatno potrebno nešto ručno podesiti i da vam neće biti teško da me uputite u pravom smeru...
hvala vam još jednom